Problem using user ratings with theme District

Front Support Plugins Support WP Reviews Plugin Problem using user ratings with theme District

This topic contains 7 replies, has 2 voices, and was last updated by  Hesham 3 years, 11 months ago.

  • Author
    Posts
  • #2445

    Christian Rosberg
    Participant

    Hi,

    I have some problems in using the user rating for posts in the theme District (http://themeforest.net/item/district-responsive-multipurpose-theme/4058457), the ratings (stars) and custom criterias don’t display in the commenting section. I have been in contact with the theme creators who says they do commenting on posts the standard WordPress way but I guess there is some difference, compared to e.g. TwentyTwelve which do display the stars for user rating (for this specific post) and the custom criterias set. See http://cirkelsag.se/tester/cirkelsagar/test-av-cirkelsag-hitachi-c6ss/ for more details.

    I guess there is something in the District theme comments.php file missing but I don’t know what. Could you please assist me in troubleshooting this? I can send you (or post) the theme’s comments.php file if that would help. I also noticed in the standard WordPress theme TwentyTwelve that custom criterias in the comments section displayed the custom criteria ID’s instead of the custom criteria description (which are displayed in the actual review box), these issues might be related?

    Br,
    Christian Rosberg

  • #2475

    Hesham
    Keymaster

    This is a possible jQuery conflict, have you tried to disable;e loading jQuery within the plugin settings?

    If this didn’t work, then probably you need to stop the theme from loading jQuery (jquery-1.10.2).

    *You must provide the ID and Title for criteria fields, if Title is not provided, then ID will be used. This specific issue is a big that have been fixed and will be released in the next update, pretty soon.

  • #2494

    Christian Rosberg
    Participant

    Hi again,

    and thanks for a quick response. I’ve already tried to disable the jquery loading in the WP Reviews settings with no luck when using the District theme. I also disabled the theme loading jquery by renaming the referenced jquery file located under wp-includes/js/jquery (a bit uncertain where the actual loading takes place) resulting in a 404 for this file and enabling the jquery loading from the WP Reviews plugin settings instead, unfortunately with no luck. I also tried with another theme, WP-Critique from Solostream, in this theme the user rating worked well after disabling the jquery loading in the WP Reviews plugin settings (not before). Any other ideas? Just let me know if you need anything more from me.

    Br,
    Christian

  • #2495

    Hesham
    Keymaster

    If you would like me to take a look, please create a temp admin account for me an send details via contact page.

  • #2518

    Christian Rosberg
    Participant

    Any news? I’ve created the temp admin account and sent you the details via your contact page but haven’t heard anything yet…

  • #2519

    Hesham
    Keymaster

    I just sent you an email, please check and get back to me. Thanks.

  • #2533

    Christian Rosberg
    Participant

    Solved. It turned out thet the District theme from ThemeWich changed the form id in comments.php from commentform to commentsubmit. After changing “back” form id to commentform the user rating worked.

    /Christian

  • #2534

    Hesham
    Keymaster

    Christian, thanks for sharing. I appreciate it.

The forum ‘WP Reviews Plugin’ is closed to new topics and replies.