Errors for custom criteria

Front Support Plugins Support WP Reviews Plugin Errors for custom criteria

This topic contains 5 replies, has 2 voices, and was last updated by  Jamie Shiller 3 years, 10 months ago.

  • Author
    Posts
  • #2642

    Jamie Shiller
    Participant

    I’ve just installed the WP Review Plugin. I’m getting errors in the custom criteria area. How can I fix the errors?

    Add custom criteria to your review (tip: fields are sortable)

    Warning: Illegal string offset ‘.$i.’ in /home/marketex/public_html/startuptoolshed.com/wp-content/plugins/wp-reviews/inc/review_meta_box.php on line 695

    Warning: Illegal string offset ‘.$i.’ in /home/marketex/public_html/startuptoolshed.com/wp-content/plugins/wp-reviews/inc/review_meta_box.php on line 696

    Warning: Illegal string offset ‘.$i.’ in /home/marketex/public_html/startuptoolshed.com/wp-content/plugins/wp-reviews/inc/review_meta_box.php on line 697
    %

    Also, I do not see a way to download the testimonails plugin. Where do I get it?

    Thanks,

    Jamie

  • #2643

    Jamie Shiller
    Participant

    I should also mention that I’m using the latest version of PHP, so that’s not the issue.

  • #2646

    Jamie Shiller
    Participant

    My web host said the issue was that the criteria values were blank and that PHP 5.4 doesn’t like blank values.
    So I added values and the errors went away.

  • #2651

    Hesham
    Keymaster

    Glad you’ve got this error disappeared. I’ve came across this with many hosts that they actually don’t upgrade to the latest version of PHP unless you ask them too. If you have the latest version of PHP, you won’t see this error at all.

    So, maybe you need to check the version that runs of your server by yourself, just to make sure.

  • #2660

    Hesham
    Keymaster

    Oh, to get the Customer Testimonial Plugin, login to your account, then click on the (Add/Renew Subscription) tab, and user code “FREE” when check out.

  • #2663

    Jamie Shiller
    Participant

    I double checked the PHP version. I’m running 5.4.19.

    PHP doesn’t like blank values which I think is why the error appears.

    See the screenshot below.

    http://screencast.com/t/4skD8KR4gu

The forum ‘WP Reviews Plugin’ is closed to new topics and replies.