Aggregate user reviews not indexed by Google

Front Support Plugins Support WP Rich Snippets Plugin Aggregate user reviews not indexed by Google

This topic contains 5 replies, has 3 voices, and was last updated by  Hesham 1 year, 11 months ago.

  • Author
    Posts
  • #5496

    jonathan griffin
    Participant

    Hi,

    This problem may have been there for a while, but I have today just narrowed it down. When searching from blocks of text from some of the user reviews for the aggregated product review they were no where to be found in Google. I tested one review with the editor only review (not aggregate), submitted it to Google via Webmaster tools and it indexed the user comments instantly.

    Something is seriously wrong here, and I am forced now to change all my site over to editor reviews to fix the problem.

    Note also, that for aggregate reviews the example with the editor reviews had significant rankings increase immediately upon changing it over.

    Can you please do an aggregate review option without the Ajax formatting, so that the reviews appear at the bottom of the page within the commenting system. This really is quite important.

    Thanks

    Jonathan

  • #5503

    jonathan griffin
    Participant

    This was very interesting, and I am unsure if there was a recent change by Google, but just changing to Editor reviews to avoid the Ajax issue recovered most of my rankings loss, and in many cases caused a rankings increase over the aggregate setting.

    Something to Note: In around June \ July there were reports that if you blocked your javascript \ stylesheets (i.e. the wordpress includes folder) then Google couldn’t tell whether adverts were above the fold, and therefore applied in many cases a Panda Penalty. Reports also indicated that this was quickly recovered when fixed. Your can find many articles by googling “Blocked javascript panda”, and one example is https://yoast.com/google-panda-robots-css-js/

    I also had this problem, and this could be another reason for my recovery so fast.

    I used AccuRanker when diagnosing as they allow you to update rankings instantly rather than once a day. I was therefore able to see immediate results on changing over, with more results I think as a result of not blocking the javascript. I tried a few versions going back to the aggregate reviews once the javascript was unblocked and the comments were not being indexed properly.

    I think more investigation is needed on this, but suffice to say, I would really appreciate if you can develop an aggregate view based on something similar to the editor layout. This eliminates the issue of the Ajax, and also allows implementation of Paging for comments.

  • #5504

    Hesham
    Keymaster

    Hi Jonathan,

    Interesting catch!

    I just don’t understand how the Google Structured Data Testing Tool is able to discover the user reviews, which Google isn’t able to do so!

    I will see what I can do about it.

  • #5506

    jonathan griffin
    Participant

    I agree, I spend 2 days and most of one night trying to resolve a massive rankings drop all of a sudden (instantly fixed by changing to editor review). It just didn’t make sense why the comments were not being indexed, when they were there in the source code on the Google Fetch. I cannot tell if it has anything to do with blocking the jquery js files or anything in robots.txt, but it didn’t seem to make a difference when checking for indexing of comments.

    Hopefully you can just modify the Editor reviews template for aggregate reviews to give an extra option to eliminate the problem for certain. If I get time, I may do more testing on a blank install, because this is really bugging me. Everything I read up on Ajax says that Google can read it, and it is definitely showing in the source code. Very frustrating.

  • #6617

    Tim Chard
    Member

    Hi Hesham,

    Has this ever been fixed? My understanding is that if I display Editor AND User reviews, Rich Snippets do not appear in the Google Search results (even in the Structured Data Testing Google provides).

    Example:

    Amrax Review (Review; Rating): ONLY Editor Rating.

    Womb Review (Product [only option to allow User Reviews even though it’s a venue]; Aggregate): Editor Rating AND User Rating.

    Amrax shows. Womb does not.

    Thanks

    • #6651

      Hesham
      Keymaster

      Tim,

      The issue mentioned in the main topic has been solved. We’ve updated the plugin and actually we’ve removed the tabs.

      I am not sure if you talking about the same issue, anyways I prefer open new thread for your question and provide links to where i can see the issue you are having so I can assist you.

The forum ‘WP Rich Snippets Plugin’ is closed to new topics and replies.